|
![]() |
Here we identify the interfaces available in the COM API and the equivalent class in the .NET API.
COM interfaces which are not relevant to the .NET API are marked 'NA'.
Core
.NET API (in Autodesk.Navisworks.Api) | COM API |
---|---|
NA | InwLBaseVec3f |
BoundingBox3D | InwLBox3f |
InwLPlane3f, InwLPlane3f2 | |
Point3D | InwLPos3f |
InwLPos3fColl | |
InwLRotation3f, InwLRotation3f2 | |
InwLTransform3f, InwLTransform3f2, InwLTransform3f3 | |
UnitVector3D | InwLUnitVec3f |
Vector3D , Color | InwLVec3f |
InwNvCamera | |
InwNvViewer | |
InwNvViewPoint, InwNvViewPoint2 | |
PropertyCategory | InwOaAttribute |
PropertyCategory | InwOaBinaryAttribute |
InwOaClipPlane | |
InwClippingPlaneColl, InwClippingPlaneColl2 | |
InwOaCommonLight | |
InwLightsColl | |
InwOaDistantLight | |
InwOaFragment, InwOaFragment2, InwOaFragment3 | |
InwSimplePrimitivesCB | |
InwSimpleVertex | |
ModelGeometry | InwOaGeometry |
ModelItem | InwOaGroup |
ModelItemCollection | InwNodeNodesColl |
PropertyCategory | InwOaMaterial |
PropertyCategory | InwOaNameAttribute |
PropertyCategory | InwOaNat64Attribute |
ModelItem | InwOaNode |
ModelGeometry | InwNodeFragsColl |
PropertyCategoryCollection | InwNodeAttributesColl |
Model | InwOaPartition, InwOaPartition2, InwOaPartition3 |
ModelItem | InwPathNodesColl |
InwOaPointLight | |
DataProperty | InwOaProperty |
PropertyCategory | InwOaPropertyAttribute |
DataPropertyCollection | InwOaPropertyColl, InwOaPropertyVec |
PublishProperties | InwOaPublishAttribute |
NA | InwOaSceneBase |
InwOaSpotLight | |
PropertyCategory | InwOaTextAttribute |
InwOaTransform | |
PropertyCategory | InwOaURLAttribute |
InwURL, InwURL2 | |
InwURLColl | |
InwOpAnimView | |
InwOpAnonView | |
InwOpComment, InwOpComment2, InwOpComment3 | |
InwCommentsColl | |
InwOpCutView | |
NA | InwOpFind |
Search | InwOpFindSpec |
SearchCondition | InwOpFindCondition |
SearchConditionCollection | InwOpFindConditionsColl |
InwOpFolderView | |
InwOpGroupView | |
InwURLOverride | |
InwURLCategory | |
InwURLCategoriesColl | |
Progress | InwOpProgress |
PropertyCategoryCollection | InwGUIPropertyNode, InwGUIPropertyNode2 |
PropertyCategory | InwGUIAttribute, InwGUIAttribute2 |
PropertyCategoryCollection | InwGUIAttributesColl |
InwOpSavedView | |
InwSavedViewsColl | |
ModelItemCollection | InwOpSelection, InwOpSelection2 |
ModelItemCollection | InwSelectionPathsColl |
InwOpSelectionSet, InwOpSelectionSet2 | |
InwSelectionSetColl | |
InwSelectionSetExColl | |
InwSelectionSetFolder | |
InwSmartTagsOpts | |
Document | InwOpState, InwOpState2, InwOpState3, InwOpState4, InwOpState5, InwOpState6, InwOpState7, InwOpState8, InwOpState9, InwOpState10 |
Document | _InwOpStateEvents |
InwOpView, InwOpView2 | |
InwUInt32Vector | |
InwUResource, InwUResource2 | |
InwUtilityObject | |
IEnumerable, ICollection, IList | InwCollBase |
NativeHandle | InwBase |
ModelItem | InwOaPath, InwOaPath2, InwOaPath3 |
ModelItemCollection.Where | InwSeekSelection |
InwGlobalProperties, InwGlobalProperties2 |
Plugin Framework
.NET API (in Autodesk.Navisworks.Api.Plugins) | COM API |
---|---|
Plugin | InwPlugin |
InwPluginLicense | |
AddInPlugin | InwExportPlugin |
Application | InwPlugin_Site |
NA | InwExportPlugin_Site |
InwPropertyPlugin, InwPropertyPlugin2 | |
InwPropertyPlugin_Site InwPropertyPlugin2_Site | |
InwOpSelectionTreeInterface | |
ApplicationPlugins | InwPluginsColl |
InwScriptParser | |
_InwScriptParserEvents | |
InwOpInternalPlugin | |
InwSelectionTreePlugin | |
InwSelectionTreePlugin_Site | |
InwOpUserFindSpecsColl | |
InwOpUserFindSpec | |
InwOpUserSelectionTreeSpec | |
InwOpUserSelectionTreePlugin |
Controls
.NET API (in Autodesk.Navisworks.Api.Controls) | COM API |
---|---|
ApplicationControl , DocumentControl, ViewControl | InwControl, InwControl2, InwControl3, InwControl4, InwControl5 |
_InwControlEvents | |
DocumentControl , ViewControl | nwControl |
NA | nwControlProp |
NA | nwOpState |
nwScriptParser | |
nwUtilityObject |
Roamer
.NET API (in Autodesk.Navisworks.Api.Automation) | COM API |
---|---|
NavisworksApplication | Inavisdoc, Inavisdoc2, Inavisdoc3 |
NavisworksApplication | Document |
Clash Detective
.NET API | COM API |
---|---|
InwClashPlugin | |
InwClashPlugin_Site | |
DocumentClash | InwOpClashElement |
ClashResult , ClashResultGroup | LnwOclTestResult |
The "Tests" property on DocumentClashTests (a SavedItemCollection) | InwClashTestsColl |
ClashTest | InwOclClashTest |
The "Children" property on ClashTest (a SavedItemCollection) | InwTestResultsColl |
ClashTest | InwOclClashTest2 |
Timeliner
.NET API | COM API |
---|---|
InwTimeLinerImpl | |
InwTimeLinerProject, InwTimeLinerProject2 | |
InwTimeLinerTask, InwTimeLinerTask2 | |
InwTimeLinerContainer, InwTimeLinerContainer2 |