WorksetPreview Class

WorksetPreview Class

Represents an accessor for workset data which can be obtained from an unopened document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBWorksetPreview
    Autodesk.Revit.DBWorkset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class WorksetPreview : IDisposable
Public Class WorksetPreview
	Implements IDisposable
public ref class WorksetPreview : IDisposable
type WorksetPreview = 
    class
        interface IDisposable
    end

The WorksetPreview type exposes the following members.

Properties
 NameDescription
Public propertyId Id of the workset.
Public propertyIsDefaultWorkset Whether the workset is the default one.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName Name of the workset.
Public propertyOwner User name of the workset.
Public propertyUniqueId UniqueId of the workset.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the WorksetPreview
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
As a base class of Workset, this class has limited access to data. WorksetPreviews are obtained from WorksharingUtils.GetUserWorksetInfo() from an unopened document.
See Also