ServerPath Class

ServerPath Class

This class represents a path to a Revit Server location, rather than a location on disk or a network drive.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBModelPath
    Autodesk.Revit.DBServerPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ServerPath : ModelPath
Public Class ServerPath
	Inherits ModelPath
public ref class ServerPath : public ModelPath
type ServerPath = 
    class
        inherit ModelPath
    end

The ServerPath type exposes the following members.

Constructors
 NameDescription
Public methodServerPath Constructs a ServerPath
Top
Properties
 NameDescription
Public propertyCentralServerPath The path to the location of the central Revit server or cloud.
(Inherited from ModelPath)
Public propertyCloudPath Whether this path represents a path on an Autodesk server such as BIM360.
(Inherited from ModelPath)
Public propertyEmpty Whether this path is empty
(Inherited from ModelPath)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ModelPath)
Public propertyRegion The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model.
(Inherited from ModelPath)
Public propertyServerPath Whether this path is a server path (as opposed to a file path or cloud path)
(Inherited from ModelPath)
Top
Methods
 NameDescription
Public methodCompare Compares this ModelPath with another
(Inherited from ModelPath)
Public methodDispose
(Inherited from ModelPath)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetModelGUID A GUID identifying the Revit cloud model.
(Inherited from ModelPath)
Public methodGetProjectGUID A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated.
(Inherited from ModelPath)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks

ServerPaths must refer to Revit models.

ServerPaths are relative to the central server location, and are of the form "RSN://{HostNodeName}/{model_path}".

The {model_path} portion is a relative path to a Revit model. For example, the following are valid server paths:

  • RSN://EXS/hospital.rvt
  • RSN://EXS.autodesk.com/Old Files/hotel2.rvt
  • RSN://EXS.autodesk.com/Old Files/Last Week/Tuesday\hotel2.rvt
The following would not be valid server paths:
  • //EXS/Old Files/.rvt
  • EXS/hospital
See Also