Revit 2025.3 API
PDFExport |
Options for PDF export

SystemObject
Autodesk.Revit.DBPDFExportOptions
Autodesk.Revit.DBPDFExportOptions
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The PDFExportOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | PDFExportOptions | Creates a default options object. |

Name | Description | |
---|---|---|
![]() | AlwaysUseRaster | If true completely use raster processing for graphics, otherwise use vector processing as much as possible. |
![]() | ColorDepth | Color depth of either black/white, gray scale or color. |
![]() | Combine | Whether export all views and sheets into one PDF file or multiple files. |
![]() | ExportQuality | The preferred export quality (DPI). |
![]() | FileName | File name of the PDF when Combine is . |
![]() | HideCropBoundaries | Whether to hide crop boundaries. |
![]() | HideReferencePlane | Whether to hide reference/work planes. |
![]() | HideScopeBoxes | Whether to hide scope boxes. |
![]() | HideUnreferencedViewTags | Whether to hide unreferenced view tags. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | MaskCoincidentLines | Whether to mask coincident lines. |
![]() | OriginOffsetX | Offset between left sides of pdf content and paper. Always stored in unit of Feet. |
![]() | OriginOffsetY | Offset between bottom sides of pdf content and paper. Always stored in unit of Feet. |
![]() | PaperFormat | Paper format. |
![]() | PaperOrientation | Paper orientation - Portrait/Landscape/Auto |
![]() | PaperPlacement | Paper placement of either center or offset from corner. |
![]() | RasterQuality | The preferred raster quality (DPI). |
![]() | ReplaceHalftoneWithThinLines | Whether to replace halftone with thin lines. |
![]() | StopOnError | Whether export process should stop when a view fails to export |
![]() | ViewLinksInBlue | Whether set view links blue. |
![]() | ZoomPercentage | Percentage of the zoom for the view. |
![]() | ZoomType | Zoom type of either fit to page or on a specific percentage. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the PDFExportOptions |
![]() | GetExportInBackground | Execute PDF export as a background process. |
![]() | GetNamingRule | Gets a copy of the naming rule. |
![]() ![]() | IsValidNamingRule | |
![]() | SetExportInBackground | Execute PDF export as a background process. |
![]() | SetNamingRule | |
See Also