ElementRecord Class

ElementRecord Class

A record in the Revit database representing an element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementRecord

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementRecord : IDisposable
Public Class ElementRecord
	Implements IDisposable
public ref class ElementRecord : IDisposable
type ElementRecord = 
    class
        interface IDisposable
    end

The ElementRecord type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyWorksetId Get Id of the workset which owns the element.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ElementRecord
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBoundingBox Gets the bounding box of the element record.
Public methodGetCategoryId Gets the category id of the element record.
Public methodGetDesignOptionId Gets the design option id of the element record.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetId Gets the id of the element record.
Public methodGetOwnerViewId Gets the element id of the owner view record.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodHasBoundingBox Determines whether this element record has a bounding box.
Public methodIsAnElementType Identifies if the element record represents an ElementType.
Public methodIsCurveDriven Identifies if the element is curve driven.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The record is used to extract basic information about an element before the element is fully expanded in memory.
See Also