ConicalFace Class

ConicalFace Class

A conical face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBFace
        Autodesk.Revit.DBConicalFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ConicalFace : Face
Public Class ConicalFace
	Inherits Face
public ref class ConicalFace : public Face
type ConicalFace = 
    class
        inherit Face
    end

The ConicalFace type exposes the following members.

Properties
 NameDescription
Public propertyAreaThe area of this face.
(Inherited from Face)
Public propertyAxisAxis of the surface.
Public propertyEdgeLoopsA collection of edge loops. Each edge loop represents one of the closed boundaries of the face.
(Inherited from Face)
Public propertyGraphicsStyleIdThe ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject)
Public propertyHalfAngleHalf angle of the surface.
Public propertyHasRegionsIdentifies if the face contains regions (which can be created, for example, by the Split Face command).
(Inherited from Face)
Public propertyIdA unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject)
Public propertyIsCyclicIndicates whether the underlying surface is periodic in the specified parametric direction.
(Inherited from Face)
Public propertyIsElementGeometryIndicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject)
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyIsTwoSidedDetermines if a face is two-sided (degenerate).
(Inherited from Face)
Public propertyMaterialElementIdThe element ID of the material from which this face is composed.
(Inherited from Face)
Public propertyOrientationMatchesSurfaceOrientation Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations.
(Inherited from Face)
Public propertyOriginOrigin of the surface.
Public propertyPeriodThe period of the underlying surface in the specified parametric direction.
(Inherited from Face)
Public propertyRadiusRadii of the surface.
Public propertyReferenceReturns a stable reference to the face.
(Inherited from Face)
Public propertyVisibilityThe visibility.
(Inherited from GeometryObject)
Top
Methods
 NameDescription
Public methodComputeDerivativesReturns the first partial derivatives of the underlying surface at the specified point.
(Inherited from Face)
Public methodComputeNormalReturns the normal vector for the face at the given point.
(Inherited from Face)
Public methodComputeSecondDerivativesReturns the second partial derivatives of the face at the specified point.
(Inherited from Face)
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Inherited from GeometryObject)
Public methodEvaluateEvaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face.
(Inherited from Face)
Public methodGetBoundingBoxReturns the UV bounding box of the face.
(Inherited from Face)
Public methodGetEdgesAsCurveLoopsReturns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges.
(Inherited from Face)
Public methodGetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject)
Public methodGetRegionsGets the face regions (created, for example, by the Split Face command) of the face.
(Inherited from Face)
Public methodGetSurfaceReturns a copy of this face's surface.
(Inherited from Face)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIntersect(Curve)Calculates the intersection of the specified curve with this face.
(Inherited from Face)
Public methodIntersect(Face)Calculates the intersection of the specified face with this face and returns the intersection results.
(Inherited from Face)
Public methodIntersect(Curve, IntersectionResultArray)Calculates the intersection of the specified curve with this face and returns the intersection results.
(Inherited from Face)
Public methodIntersect(Face, Curve)Calculates the intersection of the specified face with this face and returns the intersection results.
(Inherited from Face)
Public methodIsInside(UV)Indicates whether the specified point is within this face.
(Inherited from Face)
Public methodIsInside(UV, IntersectionResult)Indicates whether the specified point is within this face and outputs additional information about the point location.
(Inherited from Face)
Public methodProjectProjects the specified point on the face.
(Inherited from Face)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Public methodTriangulateReturns a triangular mesh approximation to the face.
(Inherited from Face)
Public methodTriangulate(Double)Returns a triangular mesh approximation to the face.
(Inherited from Face)
Top
Remarks
For details on the parameterization, refer to the documentation for ConicalSurface.
See Also