ConicalFace Class

ConicalFace Class

A conical face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBFace
        Autodesk.Revit.DBConicalFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ConicalFace : Face
Public Class ConicalFace
	Inherits Face
public ref class ConicalFace : public Face
type ConicalFace = 
    class
        inherit Face
    end

The ConicalFace type exposes the following members.

Properties
 NameDescription
Public propertyAxisAxis of the surface.
Public propertyHalfAngleHalf angle of the surface.
Public propertyOriginOrigin of the surface.
Public propertyRadiusRadii of the surface.
Top
Methods
 NameDescription
Top
Remarks
For details on the parameterization, refer to the documentation for ConicalSurface.
See Also