PlanarFace Class

PlanarFace Class

A bounded face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBFace
        Autodesk.Revit.DBPlanarFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class PlanarFace : Face
Public Class PlanarFace
	Inherits Face
public ref class PlanarFace : public Face
type PlanarFace = 
    class
        inherit Face
    end

The PlanarFace type exposes the following members.

Properties
 NameDescription
Public propertyFaceNormalNormal of the planar face.
Public propertyOriginOrigin of the surface.
Public propertyXVectorThe X-vector of the planar face.
Public propertyYVectorThe Y-vector of the planar face.
Top
Methods
 NameDescription
Top
Remarks
Planar faces are defined by planes bounded by edge loops. The planes provide natural UV parameterization to the faces. S(u, v) = Origin + u*Vector[0] + v*Vector[1]
See Also