Revit 2025.3 API
Schedule |
A filter in a schedule.

SystemObject
Autodesk.Revit.DBScheduleFilter
Autodesk.Revit.DBScheduleFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The ScheduleFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | ScheduleFilter | Creates a new ScheduleFilter. |
![]() | ScheduleFilter(ScheduleFieldId, ScheduleFilterType) | Creates a new ScheduleFilter. |
![]() | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, ElementId) | Creates a new ScheduleFilter. |
![]() | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Double) | Creates a new ScheduleFilter. |
![]() | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Int32) | Creates a new ScheduleFilter. |
![]() | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, String) | Creates a new ScheduleFilter. |

Name | Description | |
---|---|---|
![]() | FieldId | The ID of the field used to filter the schedule. |
![]() | FilterType | The filter type. |
![]() | IsDoubleValue | Indicates if the filter has a double value. |
![]() | IsElementIdValue | Indicates if the filter has an ElementId value. |
![]() | IsIntegerValue | Indicates if the filter has an integer value. |
![]() | IsNullValue | Indicates if the filter has no specified value. |
![]() | IsStringValue | Indicates if the filter has a string value. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ScheduleFilter |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetDoubleValue | Gets the filter value for a filter using a double value. |
![]() | GetElementIdValue | Gets the filter value for a filter using an ElementId value. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetIntegerValue | Gets the filter value for a filter using an integer value. |
![]() | GetStringValue | Gets the filter value for a filter using a string value. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | SetNullValue | Sets the filter to have no specified value (used for HasParameter filters). |
![]() | SetValue(Double) | Set the filter value to a double. |
![]() | SetValue(ElementId) | Set the filter value to an ElementId. |
![]() | SetValue(Int32) | Set the filter value to an integer. |
![]() | SetValue(String) | Set the filter value to a string. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |

The ScheduleFilter class represents a single filter in a schedule. A filter is a condition that must be satisfied for an element to appear in the schedule. All filters must be satisfied for an element to appear in the schedule.
A schedule can be filtered by data that is not displayed in the schedule by marking the field used for filtering as hidden using the ScheduleField.IsHidden property.
See Also