Arc Class

Arc Class

A circular arc.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBCurve
        Autodesk.Revit.DBArc

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class Arc : Curve
Public Class Arc
	Inherits Curve
public ref class Arc : public Curve
type Arc = 
    class
        inherit Curve
    end

The Arc type exposes the following members.

Properties
 NameDescription
Public propertyCenterReturns the center of the arc.
Public propertyNormalReturns the normal to the plane in which the arc is defined.
Public propertyRadiusReturns the radius of the arc.
Public propertyXDirectionReturns the X direction.
Public propertyYDirectionReturns the Y direction.
Top
Methods
 NameDescription
Public methodStatic memberCreate(XYZ, XYZ, XYZ) Creates a new geometric arc object based on three points.
Public methodStatic memberCreate(Plane, Double, Double, Double) Creates a new geometric arc object based on plane, radius, and angles.
Public methodStatic memberCreate(XYZ, Double, Double, Double, XYZ, XYZ) Creates a new geometric arc object based on center, radius, unit vectors, and angles.
Top
Remarks
The arc lies in the plane defined by center and normal.
See Also