DividedPath Class

DividedPath Class

An element that consists of a set of points distributed along a path which consists of a connected set of curves and edges.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBDividedPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class DividedPath : Element
Public Class DividedPath
	Inherits Element
public ref class DividedPath : public Element
type DividedPath = 
    class
        inherit Element
    end

The DividedPath type exposes the following members.

Properties
 NameDescription
Public propertyAssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public propertyBeginningIndent The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public propertyBoundingBoxRetrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public propertyCategoryRetrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public propertyCreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
Public propertyDemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
Public propertyDesignOptionReturns the design option to which the element belongs.
(Inherited from Element)
Public propertyDisplayNodeNumbers Controls whether the node numbers are shown when the divided path is selected
Public propertyDisplayNodes Controls whether the points of the divided path are visible
Public propertyDisplayReferenceCurves Controls whether the curves in the path are visible
Public propertyDistance The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.
Public propertyDocumentReturns the Document in which the Element resides.
(Inherited from Element)
Public propertyEndIndent The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public propertyFixedNumberOfPoints The number of points used when the layout is set to 'FixedNumber'.
Public propertyFlipped If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.
Public propertyGeometryRetrieves the geometric representation of the element.
(Inherited from Element)
Public propertyGroupId The id of the group to which an element belongs.
(Inherited from Element)
Public propertyId A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public propertyIsClosedLoop Whether or not the path forms a closed loop.
Public propertyIsCyclical True if the first and last point coincide False otherwise.
Public propertyIsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public propertyIsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public propertyLevelId The id of the level associated with the element.
(Inherited from Element)
Public propertyLocationThis property is used to find the physical location of an element within a project.
(Inherited from Element)
Public propertyMaximumDistance The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.
Public propertyMeasurementType The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').
Public propertyMinimumDistance The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.
Public propertyNameA human readable name for the Element.
(Inherited from Element)
Public propertyNumberOfPoints The total number of points of the divided surface. This combines the layout points and the intersection points.
Public propertyOwnerViewId The id of the view that owns the element.
(Inherited from Element)
Public propertyParameterBuiltInParameterRetrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public propertyParameterDefinitionRetrieves a parameter from the element based on its definition.
(Inherited from Element)
Public propertyParameterGuidRetrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Public propertyParametersRetrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyParametersMapRetrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyPinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public propertySpacingRuleJustification When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.
Public propertySpacingRuleLayout The layout determines how points are distributed along the path.
Public propertyTotalPathLength The sum of the curve lengths.
Public propertyUniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public propertyVersionGuid Get the element version Guid.
(Inherited from Element)
Public propertyViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public propertyWorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
Methods
 NameDescription
Public methodStatic memberAreCurveReferencesConnected 
Public methodArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public methodCanBeHiddenIndicates if the element can be hidden in the view.
(Inherited from Element)
Public methodCanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public methodCanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public methodCanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public methodChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Public methodStatic memberCreate(Document, IListReference) 
Public methodStatic memberCreate(Document, IListReference, ICollectionElementId) 
Public methodDeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public methodDeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public methodDeleteSubelements
(Inherited from Element)
Public methodDispose
(Inherited from Element)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public methodEvaluateParameterValues
(Inherited from Element)
Public methodFlip Toggle the flipped value
Public methodGetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public methodGetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public methodGetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public methodGetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public methodGetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetIntersectingElements Get the elements whose intersection with path produces points.
Public methodGetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public methodGetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public methodGetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public methodGetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public methodGetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public methodGetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public methodGetParameterRetrieves a parameter from the element given identifier.
(Inherited from Element)
Public methodGetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public methodGetParametersRetrieves the parameters from the element via the given name.
(Inherited from Element)
Public methodGetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public methodGetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public methodGetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public methodHasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public methodIsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodStatic memberIsCurveReferenceValid This returns true if the reference represents a curve or edge that can be used to create a divided path.
Public methodIsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public methodIsHiddenIdentifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public methodStatic memberIsIntersectorValidForCreation This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Public methodIsIntersectorValidForDividedPath This returns true if the intersector is an element that can be used to intersect with the divided path.
Public methodIsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public methodIsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public methodIsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public methodIsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public methodIsValidBeginningIndent Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public methodIsValidEndIndent Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public methodStatic memberIsValidFixedNumberOfPoints Identifies if the indicated number of points is valid for assignment to a DividedPath with a layout type 'FixedNumber'.
Public methodIsValidMeasurementType Checks that the measurement type enumeration value is valid
Public methodIsValidSpacingRuleJustification Checks that the justification enumeration value is valid
Public methodIsValidSpacingRuleLayout Checks that the spacing rule layout enumeration value is valid
Public methodIsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public methodLookupParameterAttempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public methodRefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public methodRefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public methodStatic memberSeparateReferencesIntoConnectedReferences 
Public methodSetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public methodSetIntersectingElements 
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The points can be the result of a uniform distribution along the path. The type of the distribution is determined by a selected 'layout'. The distance between the layout points depends on the path, the layout, and layout specific settings. In addition, points can also be the result of intersecting the path with other elements.
See Also