DividedPath Class

DividedPath Class

An element that consists of a set of points distributed along a path which consists of a connected set of curves and edges.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBDividedPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class DividedPath : Element
Public Class DividedPath
	Inherits Element
public ref class DividedPath : public Element
type DividedPath = 
    class
        inherit Element
    end

The DividedPath type exposes the following members.

Properties
 NameDescription
Public propertyBeginningIndent The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public propertyDisplayNodeNumbers Controls whether the node numbers are shown when the divided path is selected
Public propertyDisplayNodes Controls whether the points of the divided path are visible
Public propertyDisplayReferenceCurves Controls whether the curves in the path are visible
Public propertyDistance The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.
Public propertyEndIndent The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public propertyFixedNumberOfPoints The number of points used when the layout is set to 'FixedNumber'.
Public propertyFlipped If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.
Public propertyIsClosedLoop Whether or not the path forms a closed loop.
Public propertyIsCyclical True if the first and last point coincide False otherwise.
Public propertyMaximumDistance The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.
Public propertyMeasurementType The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').
Public propertyMinimumDistance The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.
Public propertyNumberOfPoints The total number of points of the divided surface. This combines the layout points and the intersection points.
Public propertySpacingRuleJustification When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.
Public propertySpacingRuleLayout The layout determines how points are distributed along the path.
Public propertyTotalPathLength The sum of the curve lengths.
Top
Methods
 NameDescription
Public methodStatic memberAreCurveReferencesConnected 
Public methodStatic memberCreate(Document, IListReference) 
Public methodStatic memberCreate(Document, IListReference, ICollectionElementId) 
Public methodFlip Toggle the flipped value
Public methodGetIntersectingElements Get the elements whose intersection with path produces points.
Public methodStatic memberIsCurveReferenceValid This returns true if the reference represents a curve or edge that can be used to create a divided path.
Public methodStatic memberIsIntersectorValidForCreation This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Public methodIsIntersectorValidForDividedPath This returns true if the intersector is an element that can be used to intersect with the divided path.
Public methodIsValidBeginningIndent Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public methodIsValidEndIndent Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public methodStatic memberIsValidFixedNumberOfPoints Identifies if the indicated number of points is valid for assignment to a DividedPath with a layout type 'FixedNumber'.
Public methodIsValidMeasurementType Checks that the measurement type enumeration value is valid
Public methodIsValidSpacingRuleJustification Checks that the justification enumeration value is valid
Public methodIsValidSpacingRuleLayout Checks that the spacing rule layout enumeration value is valid
Public methodStatic memberSeparateReferencesIntoConnectedReferences 
Public methodSetIntersectingElements 
Top
Remarks
The points can be the result of a uniform distribution along the path. The type of the distribution is determined by a selected 'layout'. The distance between the layout points depends on the path, the layout, and layout specific settings. In addition, points can also be the result of intersecting the path with other elements.
See Also