FamilySymbol Class

FamilySymbol Class

An element that represents a single type with a Family.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DBInsertableObject
        Autodesk.Revit.DBFamilySymbol
          More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FamilySymbol : InsertableObject
Public Class FamilySymbol
	Inherits InsertableObject
public ref class FamilySymbol : public InsertableObject
type FamilySymbol = 
    class
        inherit InsertableObject
    end

The FamilySymbol type exposes the following members.

Properties
 NameDescription
Public propertyFamily The Family object to which the symbol belongs.
Public propertyIsActive Identifies whether the symbol is active.
Public propertyStructuralMaterialTypeThis property returns the physical material from which the type is made.
Top
Methods
 NameDescription
Public methodActivate Activates the symbol to ensure that its geometry is accessible.
Public methodCanHaveStructuralSection Identifies if this FamilySymbol can have a structural section.
Public methodGetFamilyPointLocationsReturns the Point Locations for the Family Symbol.
Public methodGetStructuralSection Gets the structural section from element.
Public methodGetThermalProperties Gets the thermal properties for the given FamilySymbol.
Public methodHasThermalProperties Identifies if this FamilySymbol can include thermal properties.
Public methodSetStructuralSection Sets the structural section in element.
Public methodSetThermalProperties Sets the thermal properties for the given FamilySymbol.
Top
Remarks
Custom families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of families. The Family element represents the entire family that consists of a collection of types, such as an 'I Beam'. You can think of that object as representing the entire family file. The Family object contains a number of FamilySymbol elements. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that type placed the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project.
See Also
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DBInsertableObject
        Autodesk.Revit.DBFamilySymbol
          Autodesk.Revit.DBAnnotationSymbolType
          Autodesk.Revit.DB.ArchitectureRoomTagType
          Autodesk.Revit.DBAreaTagType
          Autodesk.Revit.DB.MechanicalSpaceTagType
          Autodesk.Revit.DBMullionType
          Autodesk.Revit.DBPanelType
          Autodesk.Revit.DB.StructureTrussType