CeilingType Class

CeilingType Class

Represents a ceiling type in Autodesk Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DBHostObjAttributes
        Autodesk.Revit.DBCeilingType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class CeilingType : HostObjAttributes
Public Class CeilingType
	Inherits HostObjAttributes
public ref class CeilingType : public HostObjAttributes
type CeilingType = 
    class
        inherit HostObjAttributes
    end

The CeilingType type exposes the following members.

Properties
 NameDescription
Public propertyThermalProperties The calculated and settable thermal properties of the CeilingType
Top
Methods
 NameDescription
Top
See Also