SpotDimension Class

SpotDimension Class

Object representing various types of SpotDimension
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBDimension
      Autodesk.Revit.DBSpotDimension

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SpotDimension : Dimension
Public Class SpotDimension
	Inherits Dimension
public ref class SpotDimension : public Dimension
type SpotDimension = 
    class
        inherit Dimension
    end

The SpotDimension type exposes the following members.

Properties
 NameDescription
Public propertyLeaderHasShoulder True is dimension has leader with shoulder, false otherwise.
Public propertyLeaderShoulderPosition Position of spot dimension's leader shoulder point.
Public propertySpotDimensionType The dimension style of this dimension.
Top
Methods
 NameDescription
Public methodCanFlip Verifies that the direction of the dimension can be flipped.
Public methodFlip Flips dimension to the other side of the host.
Top
See Also