Revit 2025.3 API
Curve |
A curve interpolating two or more points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The CurveByPoints type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsReferenceLine | |
![]() | ReferenceType | Indicates the type of reference. |
![]() | SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElementSketchPlane) |
![]() | Subcategory | The subcategory, or graphics style, of the CurveByPoints. |
![]() | Visible | Whether the point is visible when the family is loaded into a project. |

Name | Description | |
---|---|---|
![]() | GetPoints | Get the sequence of points interpolated by this curve. |
![]() | GetVisibility | Gets the visibility. |
![]() | IsExternalFileReference |
Determines whether this Element represents an external
![]() | SetPoints | Change the sequence of points interpolated by this curve. |
![]() | SetVisibility | Sets the visibility. |
![]() ![]() | SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points. |

The points to be interpolated are represented as
ReferencePoints, which must already exist in the
document. In terms of appearance and graphics control,
CurveByPoints behaves similarly to ModelCurve. The main
difference being that a ModelCurve refers to a SketchPlane,
while a CurveByPoints does not.
For more methods capable of accessing data from CurveByPoints elements,
see the static class CurveByPointsUtils.
See Also