RebarContainer Class

RebarContainer Class

An object that represents an Rebar Container Element within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.StructureRebarContainer

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RebarContainer : Element, 
	IEnumerable<RebarContainerItem>
Public Class RebarContainer
	Inherits Element
	Implements IEnumerable(Of RebarContainerItem)
public ref class RebarContainer : public Element, 
	IEnumerable<RebarContainerItem^>
type RebarContainer = 
    class
        inherit Element
        interface IEnumerable<RebarContainerItem>
    end

The RebarContainer type exposes the following members.

Properties
 NameDescription
Public propertyItemsCount The count of Items in this Rebar Container.
Public propertyPresentItemsAsSubelements Identifies if Items should be presented in schedules and tags as separate subelements.
Public propertyScheduleMark The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Top
Methods
 NameDescription
Public methodAppendItemFromCurves 
Public methodAppendItemFromCurvesAndShape 
Public methodAppendItemFromRebar Appends an Item to the RebarContainer. Fills its data on base of the Rebar. Will throw exception if given rebar is not shape driven. Will throw exception if given rebar has moved bars in set.
Public methodAppendItemFromRebarShape Appends an Item to the RebarContainer. Fills its data on base of the Rebar.
Public methodCanApplyPresentationMode Checks if a presentation mode can be applied for this RebarContainer in the given view.
Public methodClearItems Clears all the Items stored in this Rebar Container element.
Public methodContains Checks if the RebarContainer has this item as one of its members.
Public methodStatic memberCreate Creates a new instance of a Rebar Container element within the project.
Protected methodGetBasicIEnumeratorReturns an enumerator that iterates through a collection.
Public methodGetEnumeratorReturns an enumerator that iterates through a collection.
Public methodGetHostId The element that contains the rebar.
Public methodGetItem Gets the item stored in the RebarContainer at the associated index.
Public methodGetParametersManager Returns an object used to manage parameters of the Rebar Container.
Public methodGetRebarContainerIterator Returns a Rebar Container Iterator that iterates through the Rebar Container Items.
Public methodGetReinforcementRoundingManager Returns an object for managing reinforcement rounding override settings.
Public methodHasPresentationOverrides Identifies if any RebarContainerItem of this RebarContainer has overridden default presentation settings for the given view.
Public methodIsItemHidden Identifies if a given RebarContainerItem is hidden in this view.
Public methodIsUnobscuredInView Checks if this rebar container element is shown unobscured in a view.
Public methodRemoveItem Removes Item from the Rebar Container.
Public methodSetHostId The element that contains the rebar.
Public methodSetItemHiddenStatus Sets the RebarContainerItem to be hidden or unhidden in the given view.
Public methodSetUnobscuredInView Sets this rebar container element to be shown unobscured in a view.
Top
Remarks
This object is derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Rebar Container element is available only in the Autodesk Revit Structure product. It is a collection of rebar sets. Every rebar set can be modified separately.
See Also