FabricSheetType Class

FabricSheetType Class

Represents a fabric sheet type, used in the generation of fabric wires.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DB.StructureFabricSheetType

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FabricSheetType : ElementType
Public Class FabricSheetType
	Inherits ElementType
public ref class FabricSheetType : public ElementType
type FabricSheetType = 
    class
        inherit ElementType
    end

The FabricSheetType type exposes the following members.

Properties
 NameDescription
Public propertyMajorDirectionWireType The id of the FabricWireType to be used in the major direction.
Public propertyMajorEndOverhang The distance from the edge of the sheet to the last wire (measured in the major direction).
Public propertyMajorLapSpliceLength The lap splice length in the major direction.
Public propertyMajorLayoutPattern The layout pattern in the major direction.
Public propertyMajorNumberOfWires The number of wires used in the major direction (includes the first and last wires).
Public propertyMajorReinforcementArea The area of fabric divided by the spacing of the wire in the major direction. This method does not apply to custom fabric sheet
Public propertyMajorSpacing The spacing between the wires in the major direction (not including the overhangs).
Public propertyMajorStartOverhang The distance from the edge of the sheet to the first wire (measured in the major direction).
Public propertyMaterial The id of the material assigned to wires.
Public propertyMinorDirectionWireType The id of the FabricWireType to be used in the minor direction.
Public propertyMinorEndOverhang The distance from the edge of the sheet to the last wire (measured in the minor direction).
Public propertyMinorLapSpliceLength The lap splice length in the minor direction.
Public propertyMinorLayoutPattern The layout pattern in the minor direction.
Public propertyMinorNumberOfWires The number of wires used in the minor direction (includes the 1st and last wires).
Public propertyMinorReinforcementArea The area of fabric divided by the spacing of the wire in the minor direction. This method does not apply to custom fabric sheet
Public propertyMinorSpacing The spacing between the wires in the minor direction (not including the overhangs).
Public propertyMinorStartOverhang The distance from the edge of the sheet to the first wire (measured in the minor direction).
Public propertyOverallLength The length of the wire sheet (including overhangs) in the major direction.
Public propertyOverallWidth The length of the wire sheet (including overhangs) in the minor direction.
Public propertySheetMass The sheet mass.
Public propertySheetMassUnit The sheet mass per area unit.
Top
Methods
 NameDescription
Public methodStatic memberCreateDefaultFabricSheetType Creates a new FabricSheetType object with a default name.
Public methodGetReinforcementRoundingManager Returns an object for managing reinforcement rounding override settings.
Public methodGetWireItem Gets the Wire stored in the FabricSheetType at the associated index.
Public methodIsCustom Verifies if the type is Custom Fabric Sheet
Public methodIsValidMajorLapSplice Identifies if the input value is valid to be applied as the major lap splice value for this FabricSheetType.
Public methodIsValidMinorLapSplice Identifies if the input value is valid to be applied as the minor lap splice value for this FabricSheetType.
Public methodSetLayoutAsCustomPattern 
Public methodSetMajorLayoutAsActualSpacing Sets the major layout pattern as ActualSpacing, while specifying the needed parameters for this pattern.
Public methodSetMajorLayoutAsFixedNumber Sets the major layout pattern as FixedNumber, while specifying the needed parameters for this pattern.
Public methodSetMajorLayoutAsMaximumSpacing Sets the major layout pattern as MaximumSpacing, while specifying the needed parameters for this pattern.
Public methodSetMajorLayoutAsNumberWithSpacing Sets the major layout pattern as NumberWithSpacing, while specifying the needed parameters for this pattern.
Public methodSetMinorLayoutAsActualSpacing Sets the minor layout pattern as ActualSpacing, while specifying the needed parameters for this pattern.
Public methodSetMinorLayoutAsFixedNumber Sets the major layout pattern as FixedNumber, while specifying the needed parameters for this pattern.
Public methodSetMinorLayoutAsMaximumSpacing Sets the major layout pattern as MaximumSpacing, while specifying the needed parameters for this pattern.
Public methodSetMinorLayoutAsNumberWithSpacing Sets the major layout pattern as NumberWithSpacing, while specifying the needed parameters for this pattern.
Top
See Also