FabricSheetType Class

FabricSheetType Class

Represents a fabric sheet type, used in the generation of fabric wires.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DB.StructureFabricSheetType

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FabricSheetType : ElementType
Public Class FabricSheetType
	Inherits ElementType
public ref class FabricSheetType : public ElementType
type FabricSheetType = 
    class
        inherit ElementType
    end

The FabricSheetType type exposes the following members.

Properties
 NameDescription
Public propertyAssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public propertyBoundingBoxRetrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public propertyCanBeCopied Determine if this ElementType can create a copy
(Inherited from ElementType)
Public propertyCanBeDeleted Determine if this ElementType can be deleted
(Inherited from ElementType)
Public propertyCanBeRenamed Determine if this ElementType can be renamed
(Inherited from ElementType)
Public propertyCategoryRetrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public propertyCreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
Public propertyDemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
Public propertyDesignOptionReturns the design option to which the element belongs.
(Inherited from Element)
Public propertyDocumentReturns the Document in which the Element resides.
(Inherited from Element)
Public propertyFamilyName Gets the family name of this element type.
(Inherited from ElementType)
Public propertyGeometryRetrieves the geometric representation of the element.
(Inherited from Element)
Public propertyGroupId The id of the group to which an element belongs.
(Inherited from Element)
Public propertyId A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public propertyIsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public propertyIsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public propertyLevelId The id of the level associated with the element.
(Inherited from Element)
Public propertyLocationThis property is used to find the physical location of an element within a project.
(Inherited from Element)
Public propertyMajorDirectionWireType The id of the FabricWireType to be used in the major direction.
Public propertyMajorEndOverhang The distance from the edge of the sheet to the last wire (measured in the major direction).
Public propertyMajorLapSpliceLength The lap splice length in the major direction.
Public propertyMajorLayoutPattern The layout pattern in the major direction.
Public propertyMajorNumberOfWires The number of wires used in the major direction (includes the first and last wires).
Public propertyMajorReinforcementArea The area of fabric divided by the spacing of the wire in the major direction. This method does not apply to custom fabric sheet
Public propertyMajorSpacing The spacing between the wires in the major direction (not including the overhangs).
Public propertyMajorStartOverhang The distance from the edge of the sheet to the first wire (measured in the major direction).
Public propertyMaterial The id of the material assigned to wires.
Public propertyMinorDirectionWireType The id of the FabricWireType to be used in the minor direction.
Public propertyMinorEndOverhang The distance from the edge of the sheet to the last wire (measured in the minor direction).
Public propertyMinorLapSpliceLength The lap splice length in the minor direction.
Public propertyMinorLayoutPattern The layout pattern in the minor direction.
Public propertyMinorNumberOfWires The number of wires used in the minor direction (includes the 1st and last wires).
Public propertyMinorReinforcementArea The area of fabric divided by the spacing of the wire in the minor direction. This method does not apply to custom fabric sheet
Public propertyMinorSpacing The spacing between the wires in the minor direction (not including the overhangs).
Public propertyMinorStartOverhang The distance from the edge of the sheet to the first wire (measured in the minor direction).
Public propertyNameSet the name for the ElementType.
(Inherited from ElementType)
Public propertyOverallLength The length of the wire sheet (including overhangs) in the major direction.
Public propertyOverallWidth The length of the wire sheet (including overhangs) in the minor direction.
Public propertyOwnerViewId The id of the view that owns the element.
(Inherited from Element)
Public propertyParameterBuiltInParameterRetrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public propertyParameterDefinitionRetrieves a parameter from the element based on its definition.
(Inherited from Element)
Public propertyParameterGuidRetrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Public propertyParametersRetrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyParametersMapRetrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyPinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public propertySheetMass The sheet mass.
Public propertySheetMassUnit The sheet mass per area unit.
Public propertyUniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public propertyVersionGuid Get the element version Guid.
(Inherited from Element)
Public propertyViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public propertyWorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
Methods
 NameDescription
Public methodArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public methodCanBeHiddenIndicates if the element can be hidden in the view.
(Inherited from Element)
Public methodCanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public methodCanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public methodCanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public methodChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Public methodStatic memberCreateDefaultFabricSheetType Creates a new FabricSheetType object with a default name.
Public methodDeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public methodDeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public methodDeleteSubelements
(Inherited from Element)
Public methodDispose
(Inherited from Element)
Public methodDuplicate Duplicates an existing element type and assigns it a new name.
(Inherited from ElementType)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public methodEvaluateParameterValues
(Inherited from Element)
Public methodGetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public methodGetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public methodGetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public methodGetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public methodGetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public methodGetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public methodGetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public methodGetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public methodGetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public methodGetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public methodGetParameterRetrieves a parameter from the element given identifier.
(Inherited from Element)
Public methodGetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public methodGetParametersRetrieves the parameters from the element via the given name.
(Inherited from Element)
Public methodGetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public methodGetPreviewImageGet the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
(Inherited from ElementType)
Public methodGetReinforcementRoundingManager Returns an object for managing reinforcement rounding override settings.
Public methodGetSimilarTypes Obtains a set of types that are similar to this type.
(Inherited from ElementType)
Public methodGetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public methodGetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public methodGetWireItem Gets the Wire stored in the FabricSheetType at the associated index.
Public methodHasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public methodIsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsCustom Verifies if the type is Custom Fabric Sheet
Public methodIsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public methodIsHiddenIdentifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public methodIsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public methodIsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public methodIsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public methodIsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public methodIsSimilarType Checks if given type is similar to this type.
(Inherited from ElementType)
Public methodIsValidDefaultFamilyType Identifies if this type is a valid default family type for the given family category id.
(Inherited from ElementType)
Public methodIsValidMajorLapSplice Identifies if the input value is valid to be applied as the major lap splice value for this FabricSheetType.
Public methodIsValidMinorLapSplice Identifies if the input value is valid to be applied as the minor lap splice value for this FabricSheetType.
Public methodIsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public methodLookupParameterAttempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public methodRefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public methodRefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public methodSetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public methodSetLayoutAsCustomPattern 
Public methodSetMajorLayoutAsActualSpacing Sets the major layout pattern as ActualSpacing, while specifying the needed parameters for this pattern.
Public methodSetMajorLayoutAsFixedNumber Sets the major layout pattern as FixedNumber, while specifying the needed parameters for this pattern.
Public methodSetMajorLayoutAsMaximumSpacing Sets the major layout pattern as MaximumSpacing, while specifying the needed parameters for this pattern.
Public methodSetMajorLayoutAsNumberWithSpacing Sets the major layout pattern as NumberWithSpacing, while specifying the needed parameters for this pattern.
Public methodSetMinorLayoutAsActualSpacing Sets the minor layout pattern as ActualSpacing, while specifying the needed parameters for this pattern.
Public methodSetMinorLayoutAsFixedNumber Sets the major layout pattern as FixedNumber, while specifying the needed parameters for this pattern.
Public methodSetMinorLayoutAsMaximumSpacing Sets the major layout pattern as MaximumSpacing, while specifying the needed parameters for this pattern.
Public methodSetMinorLayoutAsNumberWithSpacing Sets the major layout pattern as NumberWithSpacing, while specifying the needed parameters for this pattern.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also