Revit 2025.3 API
Spec |
This class contains constants identifying specs.

SystemObject
Autodesk.Revit.DBSpecTypeId
Autodesk.Revit.DBSpecTypeId
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The SpecTypeId type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | Acceleration | Acceleration, in discipline Structural. |
![]() ![]() | AirFlow | Air Flow, in discipline HVAC. |
![]() ![]() | AirFlowDensity | Air Flow Density, in discipline HVAC. |
![]() ![]() | AirFlowDividedByCoolingLoad | Air Flow divided by Cooling Load, in discipline HVAC. |
![]() ![]() | AirFlowDividedByVolume | Air Flow divided by Volume, in discipline HVAC. |
![]() ![]() | Angle | Angle, in discipline Common. |
![]() ![]() | AngularSpeed | Angular Speed, in discipline HVAC. |
![]() ![]() | ApparentPower | Apparent Power, in discipline Electrical. |
![]() ![]() | ApparentPowerDensity | Apparent Power Density, in discipline Electrical. |
![]() ![]() | Area | Area, in discipline Common. |
![]() ![]() | AreaDividedByCoolingLoad | Area divided by Cooling Load, in discipline HVAC. |
![]() ![]() | AreaDividedByHeatingLoad | Area divided by Heating Load, in discipline HVAC. |
![]() ![]() | AreaForce | Area Force, in discipline Structural. |
![]() ![]() | AreaForceScale | Area Force Scale, in discipline Structural. |
![]() ![]() | AreaSpringCoefficient | Area Spring Coefficient, in discipline Structural. |
![]() ![]() | BarDiameter | Bar Diameter, in discipline Structural. |
![]() ![]() | CableTraySize | Cable Tray Size, in discipline Electrical. |
![]() ![]() | ColorTemperature | Color Temperature, in discipline Electrical. |
![]() ![]() | ConduitSize | Conduit Size, in discipline Electrical. |
![]() ![]() | CoolingLoad | Cooling Load, in discipline HVAC. |
![]() ![]() | CoolingLoadDividedByArea | Cooling Load divided by Area, in discipline HVAC. |
![]() ![]() | CoolingLoadDividedByVolume | Cooling Load divided by Volume, in discipline HVAC. |
![]() ![]() | CostPerArea | Cost per Area, in discipline Common. |
![]() ![]() | CostRateEnergy | Cost Rate Energy, in discipline Electrical. |
![]() ![]() | CostRatePower | Cost Rate Power, in discipline Electrical. |
![]() ![]() | CrackWidth | Crack Width, in discipline Structural. |
![]() ![]() | CrossSection | Cross Section, in discipline HVAC. |
![]() ![]() | Currency | Currency, in discipline Common. |
![]() ![]() | Current | Current, in discipline Electrical. |
![]() ![]() | Custom | Unrecognized custom spec. |
![]() ![]() | DecimalSheetLength | Decimal Sheet Length, in discipline Common. |
![]() ![]() | DemandFactor | Demand Factor, in discipline Electrical. |
![]() ![]() | Diffusivity | Diffusivity, in discipline HVAC. |
![]() ![]() | Displacement | Displacement/Deflection, in discipline Structural. |
![]() ![]() | Distance | Distance, in discipline Common. |
![]() ![]() | DuctInsulationThickness | Duct Insulation Thickness, in discipline HVAC. |
![]() ![]() | DuctLiningThickness | Duct Lining Thickness, in discipline HVAC. |
![]() ![]() | DuctSize | Duct Size, in discipline HVAC. |
![]() ![]() | Efficacy | Efficacy, in discipline Electrical. |
![]() ![]() | ElectricalFrequency | Frequency, in discipline Electrical. |
![]() ![]() | ElectricalPotential | Electrical Potential, in discipline Electrical. |
![]() ![]() | ElectricalPower | Power, in discipline Electrical. |
![]() ![]() | ElectricalPowerDensity | Power Density, in discipline Electrical. |
![]() ![]() | ElectricalResistivity | Electrical Resistivity, in discipline Electrical. |
![]() ![]() | ElectricalTemperature | Temperature, in discipline Electrical. |
![]() ![]() | ElectricalTemperatureDifference | Temperature Difference, in discipline Electrical. |
![]() ![]() | Energy | Energy, in discipline Structural. |
![]() ![]() | Factor | Factor, in discipline HVAC. |
![]() ![]() | Flow | Flow, in discipline Piping. |
![]() ![]() | FlowPerPower | Flow per Power, in discipline HVAC. |
![]() ![]() | Force | Force, in discipline Structural. |
![]() ![]() | ForceScale | Force Scale, in discipline Structural. |
![]() ![]() | HeatCapacityPerArea | Heat Capacity per Area, in discipline Energy. |
![]() ![]() | HeatGain | Heat Gain, in discipline HVAC. |
![]() ![]() | HeatingLoad | Heating Load, in discipline HVAC. |
![]() ![]() | HeatingLoadDividedByArea | Heating Load divided by Area, in discipline HVAC. |
![]() ![]() | HeatingLoadDividedByVolume | Heating Load divided by Volume, in discipline HVAC. |
![]() ![]() | HeatTransferCoefficient | Coefficient of Heat Transfer, in discipline Energy. |
![]() ![]() | HvacDensity | Density, in discipline HVAC. |
![]() ![]() | HvacEnergy | Energy, in discipline Energy. |
![]() ![]() | HvacFriction | Friction, in discipline HVAC. |
![]() ![]() | HvacMassPerTime | Mass per Time, in discipline HVAC. |
![]() ![]() | HvacPower | Power, in discipline HVAC. |
![]() ![]() | HvacPowerDensity | Power Density, in discipline HVAC. |
![]() ![]() | HvacPressure | Pressure, in discipline HVAC. |
![]() ![]() | HvacRoughness | Roughness, in discipline HVAC. |
![]() ![]() | HvacSlope | Slope, in discipline HVAC. |
![]() ![]() | HvacTemperature | Temperature, in discipline HVAC. |
![]() ![]() | HvacTemperatureDifference | Temperature Difference, in discipline HVAC. |
![]() ![]() | HvacVelocity | Velocity, in discipline HVAC. |
![]() ![]() | HvacViscosity | Dynamic Viscosity, in discipline HVAC. |
![]() ![]() | Illuminance | Illuminance, in discipline Electrical. |
![]() ![]() | IsothermalMoistureCapacity | Isothermal Moisture Capacity, in discipline Energy. |
![]() ![]() | Length | Length, in discipline Common. |
![]() ![]() | LinearForce | Linear Force, in discipline Structural. |
![]() ![]() | LinearForceScale | Linear Force Scale, in discipline Structural. |
![]() ![]() | LinearMoment | Linear Moment, in discipline Structural. |
![]() ![]() | LinearMomentScale | Linear Moment Scale, in discipline Structural. |
![]() ![]() | LineSpringCoefficient | Line Spring Coefficient, in discipline Structural. |
![]() ![]() | Luminance | Luminance, in discipline Electrical. |
![]() ![]() | LuminousFlux | Luminous Flux, in discipline Electrical. |
![]() ![]() | LuminousIntensity | Luminous Intensity, in discipline Electrical. |
![]() ![]() | Mass | Mass, in discipline Structural. |
![]() ![]() | MassDensity | Mass Density, in discipline Common. |
![]() ![]() | MassPerUnitArea | Mass per Unit Area, in discipline Structural. |
![]() ![]() | MassPerUnitLength | Mass per Unit Length, in discipline Structural. |
![]() ![]() | Moment | Moment, in discipline Structural. |
![]() ![]() | MomentOfInertia | Moment of Inertia, in discipline Structural. |
![]() ![]() | MomentScale | Moment Scale, in discipline Structural. |
![]() ![]() | Number | Number, in discipline Common. |
![]() ![]() | Period | Period, in discipline Structural. |
![]() ![]() | Permeability | Permeability, in discipline Energy. |
![]() ![]() | PipeDimension | Pipe Dimension, in discipline Piping. |
![]() ![]() | PipeInsulationThickness | Pipe Insulation Thickness, in discipline Piping. |
![]() ![]() | PipeMassPerUnitLength | Mass per Unit Length, in discipline Piping. |
![]() ![]() | PipeSize | Pipe Size, in discipline Piping. |
![]() ![]() | PipingDensity | Density, in discipline Piping. |
![]() ![]() | PipingFriction | Friction, in discipline Piping. |
![]() ![]() | PipingMass | Mass, in discipline Piping. |
![]() ![]() | PipingMassPerTime | Mass per Time, in discipline Piping. |
![]() ![]() | PipingPressure | Pressure, in discipline Piping. |
![]() ![]() | PipingRoughness | Roughness, in discipline Piping. |
![]() ![]() | PipingSlope | Slope, in discipline Piping. |
![]() ![]() | PipingTemperature | Temperature, in discipline Piping. |
![]() ![]() | PipingTemperatureDifference | Temperature Difference, in discipline Piping. |
![]() ![]() | PipingVelocity | Velocity, in discipline Piping. |
![]() ![]() | PipingViscosity | Dynamic Viscosity, in discipline Piping. |
![]() ![]() | PipingVolume | Volume, in discipline Piping. |
![]() ![]() | PointSpringCoefficient | Point Spring Coefficient, in discipline Structural. |
![]() ![]() | PowerPerFlow | Power per Flow, in discipline HVAC. |
![]() ![]() | PowerPerLength | Power per Length, in discipline Electrical. |
![]() ![]() | Pulsation | Pulsation, in discipline Structural. |
![]() ![]() | ReinforcementArea | Reinforcement Area, in discipline Structural. |
![]() ![]() | ReinforcementAreaPerUnitLength | Reinforcement Area per Unit Length, in discipline Structural. |
![]() ![]() | ReinforcementCover | Reinforcement Cover, in discipline Structural. |
![]() ![]() | ReinforcementLength | Reinforcement Length, in discipline Structural. |
![]() ![]() | ReinforcementSpacing | Reinforcement Spacing, in discipline Structural. |
![]() ![]() | ReinforcementVolume | Reinforcement Volume, in discipline Structural. |
![]() ![]() | Rotation | Rotation, in discipline Structural. |
![]() ![]() | RotationalLineSpringCoefficient | Rotational Line Spring Coefficient, in discipline Structural. |
![]() ![]() | RotationalPointSpringCoefficient | Rotational Point Spring Coefficient, in discipline Structural. |
![]() ![]() | RotationAngle | Rotation Angle, in discipline Common. |
![]() ![]() | SectionArea | Section Area, in discipline Structural. |
![]() ![]() | SectionDimension | Section Dimension, in discipline Structural. |
![]() ![]() | SectionModulus | Section Modulus, in discipline Structural. |
![]() ![]() | SectionProperty | Section Property, in discipline Structural. |
![]() ![]() | SheetLength | Sheet Length, in discipline Common. |
![]() ![]() | SiteAngle | Site Angle, in discipline Common. |
![]() ![]() | Slope | Slope, in discipline Common. |
![]() ![]() | SpecificHeat | Specific Heat, in discipline Energy. |
![]() ![]() | SpecificHeatOfVaporization | Specific Heat of Vaporization, in discipline Energy. |
![]() ![]() | Speed | Speed, in discipline Common. |
![]() ![]() | Stationing | Stationing, in discipline Infrastructure. |
![]() ![]() | StationingInterval | Stationing Interval, in discipline Infrastructure. |
![]() ![]() | Stress | Stress, in discipline Structural. |
![]() ![]() | StructuralFrequency | Frequency, in discipline Structural. |
![]() ![]() | StructuralVelocity | Velocity, in discipline Structural. |
![]() ![]() | SurfaceAreaPerUnitLength | Surface Area per Unit Length, in discipline Structural. |
![]() ![]() | ThermalConductivity | Thermal Conductivity, in discipline Energy. |
![]() ![]() | ThermalExpansionCoefficient | Thermal Expansion Coefficient, in discipline Structural. |
![]() ![]() | ThermalGradientCoefficientForMoistureCapacity | Thermal Gradient Coefficient for Moisture Capacity, in discipline Energy. |
![]() ![]() | ThermalMass | Thermal Mass, in discipline Energy. |
![]() ![]() | ThermalResistance | Thermal Resistance, in discipline Energy. |
![]() ![]() | Time | Time, in discipline Common. |
![]() ![]() | UnitWeight | Unit Weight, in discipline Structural. |
![]() ![]() | Volume | Volume, in discipline Common. |
![]() ![]() | WarpingConstant | Warping Constant, in discipline Structural. |
![]() ![]() | Wattage | Wattage, in discipline Electrical. |
![]() ![]() | Weight | Weight, in discipline Structural. |
![]() ![]() | WeightPerUnitLength | Weight per Unit Length, in discipline Structural. |
![]() ![]() | WireDiameter | Wire Diameter, in discipline Electrical. |
See Also