FabricationPart Class

FabricationPart Class

Represents a fabrication component in the Autodesk Revit MEP product.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBFabricationPart

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FabricationPart : Element
Public Class FabricationPart
	Inherits Element
public ref class FabricationPart : public Element
type FabricationPart = 
    class
        inherit Element
    end

The FabricationPart type exposes the following members.

Properties
 NameDescription
Public propertyAlias The alias of the fabrication part.
Public propertyAssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public propertyBottomOfPartElevation The associated elevation to the bottom of fabrication part off of the current level.
Public propertyBoundingBoxRetrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public propertyCategoryRetrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public propertyCenterlineLength The centerline length of the fabrication part.
Public propertyConnectorManager The connector manager of the fabrication part.
Public propertyCreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
Public propertyCutType The cut type of the fabrication part.
Public propertyDemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
Public propertyDesignOptionReturns the design option to which the element belongs.
(Inherited from Element)
Public propertyDocumentReturns the Document in which the Element resides.
(Inherited from Element)
Public propertyDomainType The domain type for the fabrication part.
Public propertyDoubleWallMaterial The double wall material identifier of the fabrication part.
Public propertyDoubleWallMaterialArea The double wall material area of the fabrication part. If the fabrication part is not double walled, returns zero.
Public propertyDoubleWallMaterialThickness The double wall material thickness of the fabrication part. If the fabrication part is not double walled, returns zero.
Public propertyFreeSize The inner size of the fabrication part.
Public propertyGeometryRetrieves the geometric representation of the element.
(Inherited from Element)
Public propertyGeometryChecksum Gets the geometry checksum of the fabrication part symbol, and it does nothing with the fabrication part instance position.
Public propertyGroupId The id of the group to which an element belongs.
(Inherited from Element)
Public propertyHangerRodKit Specifies whether an ancillary kit is being used to override support rods, bolts and clips, if any. A value of 0 indicates no override is being used.
Public propertyHasDoubleWall True if the fabrication part is double walled.
Public propertyHasInsulation True if the fabrication part is insulated.
Public propertyHasLining True if the fabrication part is lined.
Public propertyId A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public propertyInsulationArea The insulation area of the fabrication part. If the fabrication part is not insulated, returns zero.
Public propertyInsulationSpecification The fabrication part insulation specification identifier.
Public propertyInsulationThickness The insulation thickness of the fabrication part. If the fabrication part is not insulated, returns zero.
Public propertyInsulationType The insulation type of the fabrication part.
Public propertyIsBoughtOut True if the fabrication part is bought out.
Public propertyIsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public propertyIsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public propertyItemCustomId The item custom identifier for the fabrication part.
Public propertyItemNumber The item number that is used for identification, re-ordering from shop.
Public propertyLevelId The id of the level associated with the element.
(Inherited from Element)
Public propertyLevelOffset The associated level offset that indicates the distance from the center of the fabrication part to the current level.
Public propertyLiningArea The lining area of the fabrication part. If the fabrication part is not lined, returns zero.
Public propertyLiningThickness The lining thickness of the fabrication part. If the fabrication part is not lined, returns zero.
Public propertyLiningType The lining type of the fabrication part.
Public propertyLocationThis property is used to find the physical location of an element within a project.
(Inherited from Element)
Public propertyMaterial The fabrication material identifier.
Public propertyMaterialGauge The fabrication material gauge identifier.
Public propertyMaterialThickness The material thickness of the fabrication part.
Public propertyNameA human readable name for the Element.
(Inherited from Element)
Public propertyNotes The notes of the fabrication part.
Public propertyOrigin The origin of the fabrication part element.
Public propertyOverallSize The overall size of the fabrication part.
Public propertyOwnerViewId The id of the view that owns the element.
(Inherited from Element)
Public propertyParameterBuiltInParameterRetrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public propertyParameterDefinitionRetrieves a parameter from the element based on its definition.
(Inherited from Element)
Public propertyParameterGuidRetrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Public propertyParametersRetrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyParametersMapRetrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyPartGuid The fabrication part's globally unique identifier.
Public propertyPartStatus The status identifier for the fabrication part.
Public propertyPinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public propertyProductCode The current database id of the part within the fabrication database.
Public propertyProductDataRange The product data range of the fabrication part.
Public propertyProductFinishDescription The product finish description of the fabrication part.
Public propertyProductInstallType The product install type of the fabrication part.
Public propertyProductListEntry The product entry index of the fabrication part. A value of -1 indicates the fabrication part is not a product list.
Public propertyProductLongDescription The product long description of the fabrication part.
Public propertyProductMaterialDescription The product material description of the fabrication part.
Public propertyProductName The product name of the fabrication part.
Public propertyProductOriginalEquipmentManufacture The product original equipment manufacture (OEM) of the fabrication part.
Public propertyProductShortDescription The product short description of the fabrication part.
Public propertyProductSizeDescription The product size description of the fabrication part.
Public propertyProductSpecificationDescription The product specification description of the fabrication part.
Public propertyServiceAbbreviation The associated service abbreviation for the fabrication service.
Public propertyServiceId The fabrication part service identifier. The service can only be changed to compatible services.
Public propertyServiceName The name of the service associated with the fabrication part.
Public propertyServiceType The service type identifier of the fabrication part.
Public propertySheetMetalArea The sheet metal area of the fabrication part.
Public propertySize The size of the fabrication part.
Public propertySlope The slope for the straight fabrication part.
Public propertySpecification The fabrication part specification identifier.
Public propertySpoolName The spool name of the fabrication part.
Public propertyTopOfPartElevation The associated elevation to the top of fabrication part off of the current level.
Public propertyUniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public propertyValidationStatus The validation status of the fabrication part.
Public propertyVendor The vendor of the fabrication part.
Public propertyVendorCode The vendor code of the fabrication part.
Public propertyVersionGuid Get the element version Guid.
(Inherited from Element)
Public propertyViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public propertyWeight The weight of the fabrication part.
Public propertyWorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
Methods
 NameDescription
Public methodAddPartCustomData Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration.
Public methodAdjustEndLength Adjusts the length for the specified connector.
Public methodStatic memberAlignPartByConnector Align the part by its connector to a point and rotation in free space.
Public methodStatic memberAlignPartByConnectors Moves fabrication part by one of its connectors and aligns it to another connector.
Public methodStatic memberAlignPartByConnectorToConnector Align a part by its connector to another connector. This will replace the FabricationPart::AlignPartByConnectors method.
Public methodStatic memberAlignPartByInsertionPoint Align the part by its insertion point to a point and rotation in free space.
Public methodStatic memberAlignPartByInsertionPointAndCutInToStraight Align the part by its insertion point to a point and rotation on a straight. This will automatically size and connect the part being cut into, if possible.
Public methodArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public methodCanAdjustEndLength Checks if the end of fabrication part can be adjusted.
Public methodCanASlopeBeApplied This will test if a slope can be applied to the part and maintain connections with any connected parts.
Public methodCanBeHiddenIndicates if the element can be hidden in the view.
(Inherited from Element)
Public methodCanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public methodCanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public methodCanFlipPart Validates if the fabrication part is one of the supported fabrication part types that can be flipped.
Public methodCanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public methodCanSplitStraight Validates if the straight can be split into two at the passed in point.
Public methodChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Public methodStatic memberConnectAndCouple Makes a connection between the specified connectors and adds coupling if necessary.
Public methodStatic memberCreate(Document, FabricationItemFile, ElementId) Creates a fabrication part element from a fabrication item file.
Public methodStatic memberCreate(Document, FabricationServiceButton, Int32, ElementId) Creates a fabrication part element based on button.
Public methodStatic memberCreate(Document, FabricationServiceButton, Double, Double, ElementId) Creates a fabrication part element based on button and size.
Public methodStatic memberCreateHanger(Document, FabricationServiceButton, Int32, ElementId) Creates a free placed hanger.
Public methodStatic memberCreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) Creates a hanger on the fabrication part.
Public methodStatic memberCreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) Creates a hanger on the fabrication part.
Public methodDeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public methodDeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public methodDeleteSubelements
(Inherited from Element)
Public methodDispose
(Inherited from Element)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public methodEvaluateParameterValues
(Inherited from Element)
Public methodFlip Flips the fabrication part that is directionally oriented (tees, crosses, valves, dampers, etc.) to the opposite direction.
Public methodGetCalculatedDimensionValue Gets the calculated dimension value.
Public methodGetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public methodGetDimensionCalculatedOptions Gets the calculated options of the fabrication dimension.
Public methodGetDimensions Gets all fabrication dimensions.
Public methodGetDimensionValue Gets the value of the fabrication dimension, returns value in Revit internal units.
Public methodGetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public methodGetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public methodGetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public methodGetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetHostedInfo Gets the fabrication hosted element information.
Public methodGetInsulationLiningGeometry Gets insulation and lining geometry for this fabrication part.
Public methodGetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public methodGetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public methodGetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public methodGetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public methodGetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public methodGetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public methodGetParameterRetrieves a parameter from the element given identifier.
(Inherited from Element)
Public methodGetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public methodGetParametersRetrieves the parameters from the element via the given name.
(Inherited from Element)
Public methodGetPartAncillaryUsage Gets a list of all ancillary usage information for the part.
Public methodGetPartCustomDataInteger Get custom data integer value for the specified custom data.
Public methodGetPartCustomDataReal Get custom data real value for the specified custom data.
Public methodGetPartCustomDataText Get custom data text for the specified custom data.
Public methodGetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public methodGetProductListEntryCount Gets the number of product entries for this part.
Public methodGetProductListEntryName Gets the specified product list entry name.
Public methodGetRodInfo Gets the fabrication rod information.
Public methodGetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public methodGetTransform Gets the transformation matrix of the fabrication part element.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public methodGetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public methodGetVersionHistory Gets a history of version change information about the current part.
Public methodHasCustomData Check if fabrication part contains custom data already.
Public methodHasNoConnections Checks to see if all the fabrication part's connectors are open.
Public methodHasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public methodIsAHanger Checks whether it is a hanger.
Public methodIsAStraight Checks whether it is a straight part.
Public methodIsATap Checks if it is any sort of tap.
Public methodIsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsDimensionCalculated Checks if the fabrication dimension is calculated.
Public methodIsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public methodIsHiddenIdentifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public methodIsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public methodIsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public methodIsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public methodIsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public methodIsProductList Gets whether or not the fabrication part is a product list.
Public methodIsProductListEntryCompatibleSize Checks to see if this part can be changed to the specified product entry without altering any connected dimensions.
Public methodIsSameAs 
Public methodIsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public methodLookupParameterAttempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public methodStatic memberOptimizeLengths 
Public methodStatic memberPlaceAsTap Places the part by its connector to a specific position on the straight part at the specified distance from the host part connector.
Public methodStatic memberPlaceFittingAsCutIn Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position.
Public methodRefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public methodRefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public methodRemovePartCustomData Remove custom data from the fabrication part.
Public methodStatic memberReposition Repositions the fabrication straight part to another end of the run.
Public methodStatic memberRotateConnectedPartByConnector Rotates a connected fabrication part around the axis of the specified connector.
Public methodStatic memberRotateConnectedTap Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.
Public methodStatic memberSaveAsFabricationJob 
Public methodSetCalculatedDimensionValue Sets the calculated dimension value.
Public methodSetDimensionValue Sets the fabrication dimension value. The value is in Revit internal units.
Public methodSetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public methodSetPartCustomDataInteger Set the custom data integer value for the specified custom data.
Public methodSetPartCustomDataReal Set the custom data real value for the specified custom data.
Public methodSetPartCustomDataText Set the custom data real value for the specified custom data.
Public methodSetPositionByEnd Positions the connector of the fabrication part element by the passed point.
Public methodSplitStraight(XYZ) Splits the straight into two at the passed in point.
Public methodSplitStraight(Document, ElementId, XYZ) Splits the straight into two at the passed in point.
Public methodStatic memberStretchAndFit 
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also