FabricationPart Class

FabricationPart Class

Represents a fabrication component in the Autodesk Revit MEP product.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBFabricationPart

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FabricationPart : Element
Public Class FabricationPart
	Inherits Element
public ref class FabricationPart : public Element
type FabricationPart = 
    class
        inherit Element
    end

The FabricationPart type exposes the following members.

Properties
 NameDescription
Public propertyAlias The alias of the fabrication part.
Public propertyBottomOfPartElevation The associated elevation to the bottom of fabrication part off of the current level.
Public propertyCenterlineLength The centerline length of the fabrication part.
Public propertyConnectorManager The connector manager of the fabrication part.
Public propertyCutType The cut type of the fabrication part.
Public propertyDomainType The domain type for the fabrication part.
Public propertyDoubleWallMaterial The double wall material identifier of the fabrication part.
Public propertyDoubleWallMaterialArea The double wall material area of the fabrication part. If the fabrication part is not double walled, returns zero.
Public propertyDoubleWallMaterialThickness The double wall material thickness of the fabrication part. If the fabrication part is not double walled, returns zero.
Public propertyFreeSize The inner size of the fabrication part.
Public propertyGeometryChecksum Gets the geometry checksum of the fabrication part symbol, and it does nothing with the fabrication part instance position.
Public propertyHangerRodKit Specifies whether an ancillary kit is being used to override support rods, bolts and clips, if any. A value of 0 indicates no override is being used.
Public propertyHasDoubleWall True if the fabrication part is double walled.
Public propertyHasInsulation True if the fabrication part is insulated.
Public propertyHasLining True if the fabrication part is lined.
Public propertyInsulationArea The insulation area of the fabrication part. If the fabrication part is not insulated, returns zero.
Public propertyInsulationSpecification The fabrication part insulation specification identifier.
Public propertyInsulationThickness The insulation thickness of the fabrication part. If the fabrication part is not insulated, returns zero.
Public propertyInsulationType The insulation type of the fabrication part.
Public propertyIsBoughtOut True if the fabrication part is bought out.
Public propertyItemCustomId The item custom identifier for the fabrication part.
Public propertyItemNumber The item number that is used for identification, re-ordering from shop.
Public propertyLevelOffset The associated level offset that indicates the distance from the center of the fabrication part to the current level.
Public propertyLiningArea The lining area of the fabrication part. If the fabrication part is not lined, returns zero.
Public propertyLiningThickness The lining thickness of the fabrication part. If the fabrication part is not lined, returns zero.
Public propertyLiningType The lining type of the fabrication part.
Public propertyMaterial The fabrication material identifier.
Public propertyMaterialGauge The fabrication material gauge identifier.
Public propertyMaterialThickness The material thickness of the fabrication part.
Public propertyNotes The notes of the fabrication part.
Public propertyOrigin The origin of the fabrication part element.
Public propertyOverallSize The overall size of the fabrication part.
Public propertyPartGuid The fabrication part's globally unique identifier.
Public propertyPartStatus The status identifier for the fabrication part.
Public propertyProductCode The current database id of the part within the fabrication database.
Public propertyProductDataRange The product data range of the fabrication part.
Public propertyProductFinishDescription The product finish description of the fabrication part.
Public propertyProductInstallType The product install type of the fabrication part.
Public propertyProductListEntry The product entry index of the fabrication part. A value of -1 indicates the fabrication part is not a product list.
Public propertyProductLongDescription The product long description of the fabrication part.
Public propertyProductMaterialDescription The product material description of the fabrication part.
Public propertyProductName The product name of the fabrication part.
Public propertyProductOriginalEquipmentManufacture The product original equipment manufacture (OEM) of the fabrication part.
Public propertyProductShortDescription The product short description of the fabrication part.
Public propertyProductSizeDescription The product size description of the fabrication part.
Public propertyProductSpecificationDescription The product specification description of the fabrication part.
Public propertyServiceAbbreviation The associated service abbreviation for the fabrication service.
Public propertyServiceId The fabrication part service identifier. The service can only be changed to compatible services.
Public propertyServiceName The name of the service associated with the fabrication part.
Public propertyServiceType The service type identifier of the fabrication part.
Public propertySheetMetalArea The sheet metal area of the fabrication part.
Public propertySize The size of the fabrication part.
Public propertySlope The slope for the straight fabrication part.
Public propertySpecification The fabrication part specification identifier.
Public propertySpoolName The spool name of the fabrication part.
Public propertyTopOfPartElevation The associated elevation to the top of fabrication part off of the current level.
Public propertyValidationStatus The validation status of the fabrication part.
Public propertyVendor The vendor of the fabrication part.
Public propertyVendorCode The vendor code of the fabrication part.
Public propertyWeight The weight of the fabrication part.
Top
Methods
 NameDescription
Public methodAddPartCustomData Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration.
Public methodAdjustEndLength Adjusts the length for the specified connector.
Public methodStatic memberAlignPartByConnector Align the part by its connector to a point and rotation in free space.
Public methodStatic memberAlignPartByConnectors Moves fabrication part by one of its connectors and aligns it to another connector.
Public methodStatic memberAlignPartByConnectorToConnector Align a part by its connector to another connector. This will replace the FabricationPart::AlignPartByConnectors method.
Public methodStatic memberAlignPartByInsertionPoint Align the part by its insertion point to a point and rotation in free space.
Public methodStatic memberAlignPartByInsertionPointAndCutInToStraight Align the part by its insertion point to a point and rotation on a straight. This will automatically size and connect the part being cut into, if possible.
Public methodCanAdjustEndLength Checks if the end of fabrication part can be adjusted.
Public methodCanASlopeBeApplied This will test if a slope can be applied to the part and maintain connections with any connected parts.
Public methodCanFlipPart Validates if the fabrication part is one of the supported fabrication part types that can be flipped.
Public methodCanSplitStraight Validates if the straight can be split into two at the passed in point.
Public methodStatic memberConnectAndCouple Makes a connection between the specified connectors and adds coupling if necessary.
Public methodStatic memberCreate(Document, FabricationItemFile, ElementId) Creates a fabrication part element from a fabrication item file.
Public methodStatic memberCreate(Document, FabricationServiceButton, Int32, ElementId) Creates a fabrication part element based on button.
Public methodStatic memberCreate(Document, FabricationServiceButton, Double, Double, ElementId) Creates a fabrication part element based on button and size.
Public methodStatic memberCreateHanger(Document, FabricationServiceButton, Int32, ElementId) Creates a free placed hanger.
Public methodStatic memberCreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) Creates a hanger on the fabrication part.
Public methodStatic memberCreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) Creates a hanger on the fabrication part.
Public methodFlip Flips the fabrication part that is directionally oriented (tees, crosses, valves, dampers, etc.) to the opposite direction.
Public methodGetCalculatedDimensionValue Gets the calculated dimension value.
Public methodGetDimensionCalculatedOptions Gets the calculated options of the fabrication dimension.
Public methodGetDimensions Gets all fabrication dimensions.
Public methodGetDimensionValue Gets the value of the fabrication dimension, returns value in Revit internal units.
Public methodGetHostedInfo Gets the fabrication hosted element information.
Public methodGetInsulationLiningGeometry Gets insulation and lining geometry for this fabrication part.
Public methodGetPartAncillaryUsage Gets a list of all ancillary usage information for the part.
Public methodGetPartCustomDataInteger Get custom data integer value for the specified custom data.
Public methodGetPartCustomDataReal Get custom data real value for the specified custom data.
Public methodGetPartCustomDataText Get custom data text for the specified custom data.
Public methodGetProductListEntryCount Gets the number of product entries for this part.
Public methodGetProductListEntryName Gets the specified product list entry name.
Public methodGetRodInfo Gets the fabrication rod information.
Public methodGetTransform Gets the transformation matrix of the fabrication part element.
Public methodGetVersionHistory Gets a history of version change information about the current part.
Public methodHasCustomData Check if fabrication part contains custom data already.
Public methodHasNoConnections Checks to see if all the fabrication part's connectors are open.
Public methodIsAHanger Checks whether it is a hanger.
Public methodIsAStraight Checks whether it is a straight part.
Public methodIsATap Checks if it is any sort of tap.
Public methodIsDimensionCalculated Checks if the fabrication dimension is calculated.
Public methodIsProductList Gets whether or not the fabrication part is a product list.
Public methodIsProductListEntryCompatibleSize Checks to see if this part can be changed to the specified product entry without altering any connected dimensions.
Public methodIsSameAs 
Public methodStatic memberOptimizeLengths 
Public methodStatic memberPlaceAsTap Places the part by its connector to a specific position on the straight part at the specified distance from the host part connector.
Public methodStatic memberPlaceFittingAsCutIn Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position.
Public methodRemovePartCustomData Remove custom data from the fabrication part.
Public methodStatic memberReposition Repositions the fabrication straight part to another end of the run.
Public methodStatic memberRotateConnectedPartByConnector Rotates a connected fabrication part around the axis of the specified connector.
Public methodStatic memberRotateConnectedTap Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.
Public methodStatic memberSaveAsFabricationJob 
Public methodSetCalculatedDimensionValue Sets the calculated dimension value.
Public methodSetDimensionValue Sets the fabrication dimension value. The value is in Revit internal units.
Public methodSetPartCustomDataInteger Set the custom data integer value for the specified custom data.
Public methodSetPartCustomDataReal Set the custom data real value for the specified custom data.
Public methodSetPartCustomDataText Set the custom data real value for the specified custom data.
Public methodSetPositionByEnd Positions the connector of the fabrication part element by the passed point.
Public methodSplitStraight(XYZ) Splits the straight into two at the passed in point.
Public methodSplitStraight(Document, ElementId, XYZ) Splits the straight into two at the passed in point.
Public methodStatic memberStretchAndFit 
Top
See Also